Abiword léger pour Archlinux

Je remercie principalement les développeurs de Abiword, qui sur leur canal IRC,  Get help, m’ont donné les indications utiles pour pouvoir compiler un Abiword sans dépendances superflues.

Pour la version 2.6.6, il faut installer  libgnomecanvas, libgnomeprint, libgnomeprintui.

Pour libgnomecanvas, il faut libglade et libart-lgpl. Ce dernier est aussi nécessaire pour libgnomeprint qui réclame aussi libgnomecups.

Il a aussi fallu installer fribidi et wv.

Cela fait 8 paquets à compiler ou installer au total, en plus de Abiword. (wv, fridibi et libart-lgpl s’installent sans dépendance supplémentaire aussi il n’est pas obligatoire de les compiler)

Si on installe la version packagée de Abiword, voici ce qui se présente:

Résolution des dépendances…
Avertissement: Une provision a été sélectionnée (esound fournit esd)
Recherche des conflits possibles entre paquets…

Cibles (21): fribidi-0.10.9-1  libart-lgpl-2.3.20-1  libgnomecups-0.2.3-4
libgnomeprint-2.18.5-1  libgnomecanvas-2.20.1.1-2
libgnomeprintui-2.18.3-1  wv-1.2.4-1  libdaemon-0.13-1
avahi-0.6.24-1  tdb-3.2.7-1  smbclient-3.2.7-1
gnome-mime-data-2.18.0-3  gnome-vfs-2.24.0-2  libbonobo-2.24.0-1
audiofile-0.2.6-3  esound-0.2.41-1  libgnome-2.24.1-1
libbonoboui-2.24.0-1  libgnomeui-2.24.0-1  libgsf-gnome-1.14.11-1
abiword-2.6.6-1

Taille totale des paquets (téléchargement):   25,67 Mo
Taille totale des paquets (installation):   100,31 Mo

Je préfère éviter avahi, smb, les fichiers pour l’audio, etc, lors de l’installation d’un traitement de textes.

Advertisements

#abiword